Antique Radios Forum

This is the temporary home of the Antique Radio Forums while a new server to host it is being found. You will have to register here to post. Please Note: None of these topics will be preserved when the original forums are back.
 
HomeCalendarFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 Any problems with the EH6973 tube?

View previous topic View next topic Go down 
AuthorMessage
Bob D.



Posts : 13
Join date : 2010-10-13

PostSubject: Any problems with the EH6973 tube?   Mon Oct 18, 2010 1:54 pm

Is the EH6973 a real 6973 or a substitute? Look wise, it's obviously not identical. I guess all I really need to know is if it will function in a 9673 circuit.

BTW, my amp uses 6973s push-pull with 350V on the plates and -30V fixed bias.

Bobby D.
Back to top Go down
View user profile
Johnnysan



Posts : 64
Join date : 2010-10-12

PostSubject: Re: Any problems with the EH6973 tube?   Mon Oct 18, 2010 1:56 pm

I think the bias should be more like -22 with 350 volts on the plates.
Back to top Go down
View user profile
 
Any problems with the EH6973 tube?
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» DARKSEID BAF Problems...
» Photobucket Problems
» AA problems
» Diablo 2: Problems and Solutions
» Software for solving chess problems / puzzles / endgame studies List

Permissions in this forum:You cannot reply to topics in this forum
Antique Radios Forum :: Antique Radio Forums :: Electrical/Mechanical Restoration-
Jump to: