Antique Radios Forum

This is the temporary home of the Antique Radio Forums while a new server to host it is being found. You will have to register here to post. Please Note: None of these topics will be preserved when the original forums are back.
 
HomeCalendarFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 1960's Zenith radio/record player power issues and update with pics

View previous topic View next topic Go down 
AuthorMessage
systematicSelym

avatar

Posts : 4
Join date : 2010-10-18
Age : 26
Location : Phoenix, AZ

PostSubject: 1960's Zenith radio/record player power issues and update with pics   Wed Oct 20, 2010 4:27 pm

So I've finally taken it apart and gotten everything separated. And my power cord is CUT. I don't know why it would be, all of the tubes look great, and the fuse is in perfect condition. The only thing that doesn't appear to be in working order is the dial for the radio, and even then just barely. The dial slips a little on the track but thats it. I really want to get some power going to this thing to see for sure whats working and what isn't.
Anyways, in the end I'm going to have to splice the proper cord with whats left of the remaining one. Unless anyone has any better suggestions. Let me know.
There was also a surprising amount of cat food under the record player....










Back to top Go down
View user profile
ggregg



Posts : 30
Join date : 2010-10-12

PostSubject: Re: 1960's Zenith radio/record player power issues and update with pics   Wed Oct 20, 2010 5:32 pm

A lot of shops used to cut the cord. It usually was done to sets that were abandoned by their owner or the owner told them to keep it instead of fixing it. The cord was cut for these reasons, a set that had little or not value (remember it may have happened 40 years ago, things are a lot different now) and would probably be eventually junked, the shop was going to keep it as a parts set (they may not have parted anything out of it yet), or it was a hopeless repair (one that would cost more than the set was worth so no use in trying to resell). The cord was cut so it wouldn't be confused with another customers set. I've picked up a number of sets with cut cords over the years, some worked, some didn't.
Back to top Go down
View user profile
 
1960's Zenith radio/record player power issues and update with pics
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» RFACTOR 2 is it???
» Best way to power PF F7 locomotives
» Valkyrie Construction Issues
» WFB Player Availability
» Practicing With Exceptional Power.

Permissions in this forum:You cannot reply to topics in this forum
Antique Radios Forum :: Antique Radio Forums :: Electrical/Mechanical Restoration-
Jump to: